Okay
  Public Ticket #1849941
pre packaged plug ins list
Open

Comments

  • michael started the conversation

    Can you supply the original list of required /recommended plugins that comes with the theme. I built this site 4 years ago and handed it off to someone to manage. It has been thru a few hands and plug ins have been added (over 50 at one period of time) i am now administering the site again and trying to optimize as much as i can. Reducing unnecessary plug in etc. I want to make sure i do not delete plug ins that came with the theme.

    i have looked thru the plug ins folder in the downlaod but it only shows the added premium ones...thx 

  •  116
    Charles replied

    Hi Michael, 

    Polytechnic comes with several plugins that are advertised in the demo. The theme does not "require" these plugins, since many users may want to remove/swap/update according to their requirements, but they are included as recommended since they are supported in the theme styles/functions. For example, users may want to use their own Contact Forms plugin instead of the one included/recommended, so the ability to remove included plugins is provided. In your case, it will depend on what functionality or content you are using.

    For more information on plugins, please see the documentation for Polytechnic part 2.1 (attached).

    Below, I'm providing the full list of possible included plugins, including the current settings for these also in case you need it (ie, the location the theme is referencing to install these).

     // PREMIUM THEME PLUGINS (INCLUDED IN THEME)
            array(
                'name'                  => 'Polytechnic Courses', // The plugin name
                'slug'                  => 'polytechnic-courses', // The plugin slug (typically the folder name)
                'source'                => get_stylesheet_directory() . '/theme-core/theme-plugins/polytechnic-courses.zip', // The plugin source
                'required'              => false, // If false, the plugin is only 'recommended' instead of required
                'version'               => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
                'force_activation'      => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
                'force_deactivation'    => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
                'external_url'          => '', // If set, overrides default API URL and points to an external URL
            ),
            array(
                'name'                  => 'Theme Customizer: Polytechnic', // The plugin name
                'slug'                  => 'styles-polytechnic', // The plugin slug (typically the folder name)
                'source'                => get_stylesheet_directory() . '/theme-core/theme-plugins/styles-polytechnic.zip', // The plugin source
                'required'              => false, // If false, the plugin is only 'recommended' instead of required
                'version'               => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
                'force_activation'      => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
                'force_deactivation'    => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
                'external_url'          => '', // If set, overrides default API URL and points to an external URL
            ),
            array(
                'name'                  => 'Visual Composer', // The plugin name
                'slug'                  => 'js_composer', // The plugin slug (typically the folder name)
                'source'                => get_stylesheet_directory() . '/mythology-core/core-plugins/js_composer.zip', // The plugin source
                'required'              => false, // If false, the plugin is only 'recommended' instead of required
                'version'               => '4.2.3', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
                'force_activation'      => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
                'force_deactivation'    => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
                'external_url'          => '', // If set, overrides default API URL and points to an external URL
            ),
            array(
                'name'                  => 'Slider Revolution', // The plugin name
                'slug'                  => 'revslider', // The plugin slug (typically the folder name)
                'source'                => get_stylesheet_directory() . '/mythology-core/core-plugins/revslider.zip', // The plugin source
                'required'              => false, // If false, the plugin is only 'recommended' instead of required
                'version'               => '4.5.9', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
                'force_activation'      => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
                'force_deactivation'    => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
                'external_url'          => '' // If set, overrides default API URL and points to an external URL
            ),
    // CORE FRAMEWORK PLUGINS (HOSTED ON WP)
            
            array(
                'name'                  => 'Theme Customizer: Base Package', // The plugin name
                'slug'                  => 'styles', // The plugin slug (typically the folder name)
                'source'                => 'https://downloads.wordpress.org/plugin/styles.latest-stable.zip', // The plugin source
                'required'              => false, // If false, the plugin is only 'recommended' instead of required
                'version'               => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
                'force_activation'      => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
                'force_deactivation'    => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
                'external_url'          => '', // If set, overrides default API URL and points to an external URL
            ),
    // CORE THEME PLUGINS (HOSTED ON WP)
            array(
                'name'                  => 'Contact Form 7', // The plugin name
                'slug'                  => 'contact-form-7', // The plugin slug (typically the folder name)
                'source'                => 'https://downloads.wordpress.org/plugin/contact-form-7.latest-stable.zip', // The plugin source
                'required'              => false, // If false, the plugin is only 'recommended' instead of required
                'version'               => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
                'force_activation'      => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
                'force_deactivation'    => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
                'external_url'          => '', // If set, overrides default API URL and points to an external URL
            )
            array(
                'name'                  => 'Max Mega Menu', // The plugin name
                'slug'                  => 'megamenu', // The plugin slug (typically the folder name)
                'source'                => 'https://downloads.wordpress.org/plugin/megamenu.latest-stable.zip', // The plugin source
                'required'              => false, // If false, the plugin is only 'recommended' instead of required
                'version'               => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
                'force_activation'      => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
                'force_deactivation'    => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
                'external_url'          => '', // If set, overrides default API URL and points to an external URL
            ),
            array(
                'name'                  => 'Responsive Menu', // The plugin name
                'slug'                  => 'responsive-menu', // The plugin slug (typically the folder name)
                'source'                => 'https://downloads.wordpress.org/plugin/responsive-menu.latest-stable.zip', // The plugin source
                'required'              => false, // If false, the plugin is only 'recommended' instead of required
                'version'               => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
                'force_activation'      => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
                'force_deactivation'    => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
                'external_url'          => '', // If set, overrides default API URL and points to an external URL
            ),
            array(
                'name'                  => 'Custom Menu Wizard', // The plugin name
                'slug'                  => 'custom-menu-wizard', // The plugin slug (typically the folder name)
                'source'                => 'https://downloads.wordpress.org/plugin/custom-menu-wizard.latest-stable.zip', // The plugin source
                'required'              => false, // If false, the plugin is only 'recommended' instead of required
                'version'               => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
                'force_activation'      => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
                'force_deactivation'    => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
                'external_url'          => '', // If set, overrides default API URL and points to an external URL
            ),
            array(
                'name'                  => 'Recent Posts Widget Extended', // The plugin name
                'slug'                  => 'recent-posts-widget-extended', // The plugin slug (typically the folder name)
                'source'                => 'https://downloads.wordpress.org/plugin/recent-posts-widget-extended.latest-stable.zip', // The plugin source
                'required'              => false, // If false, the plugin is only 'recommended' instead of required
                'version'               => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
                'force_activation'      => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
                'force_deactivation'    => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
                'external_url'          => '', // If set, overrides default API URL and points to an external URL
            ),
            array(
                'name'                  => 'Image Widget', // The plugin name
                'slug'                  => 'image-widget', // The plugin slug (typically the folder name)
                'source'                => 'https://downloads.wordpress.org/plugin/image-widget.latest-stable.zip', // The plugin source
                'required'              => false, // If false, the plugin is only 'recommended' instead of required
                'version'               => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
                'force_activation'      => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
                'force_deactivation'    => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
                'external_url'          => '', // If set, overrides default API URL and points to an external URL
            ),
            array(
                'name'                  => 'WooCommerce', // The plugin name
                'slug'                  => 'woocommerce', // The plugin slug (typically the folder name)
                'source'                => 'https://downloads.wordpress.org/plugin/woocommerce.latest-stable.zip', // The plugin source
                'required'              => false, // If false, the plugin is only 'recommended' instead of required
                'version'               => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
                'force_activation'      => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
                'force_deactivation'    => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
                'external_url'          => '', // If set, overrides default API URL and points to an external URL
            ),
            array(
                'name'                  => 'The Events Calander', // The plugin name
                'slug'                  => 'the-events-calendar', // The plugin slug (typically the folder name)
                'source'                => 'https://downloads.wordpress.org/plugin/the-events-calendar.latest-stable.zip', // The plugin source
                'required'              => false, // If false, the plugin is only 'recommended' instead of required
                'version'               => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
                'force_activation'      => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
                'force_deactivation'    => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
                'external_url'          => '', // If set, overrides default API URL and points to an external URL
            ),
            array(
                'name'                  => 'Shortcodes Ultimate', // The plugin name
                'slug'                  => 'shortcodes-ultimate', // The plugin slug (typically the folder name)
                'source'                => 'https://downloads.wordpress.org/plugin/shortcodes-ultimate.zip', // The plugin source
                'required'              => false, // If false, the plugin is only 'recommended' instead of required
                'version'               => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
                'force_activation'      => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
                'force_deactivation'    => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
                'external_url'          => '', // If set, overrides default API URL and points to an external URL
            ),
            array(
                'name'                  => 'Dynamic To Top', // The plugin name
                'slug'                  => 'dynamic-to-top', // The plugin slug (typically the folder name)
                'source'                => get_stylesheet_directory() . '/theme-core/theme-plugins/dynamic-to-top.zip', // The plugin source
                'required'              => false, // If false, the plugin is only 'recommended' instead of required
                'version'               => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
                'force_activation'      => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
                'force_deactivation'    => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
                'external_url'          => '', // If set, overrides default API URL and points to an external URL
            ),
            array(
                'name'                  => 'Live Search Plugin', // The plugin name
                'slug'                  => 'ajaxy-search-form', // The plugin slug (typically the folder name)
                'source'                => get_stylesheet_directory() . '/theme-core/theme-plugins/ajaxy-search-form.zip', // The plugin source
                'required'              => false, // If false, the plugin is only 'recommended' instead of required
                'version'               => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
                'force_activation'      => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
                'force_deactivation'    => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
                'external_url'          => '', // If set, overrides default API URL and points to an external URL
            ),
            array(
                'name'                  => 'WordPress Importer', // The plugin name
                'slug'                  => 'wordpress-importer', // The plugin slug (typically the folder name)
                'source'                => 'https://downloads.wordpress.org/plugin/wordpress-importer.zip', // The plugin source
                'required'              => false, // If false, the plugin is only 'recommended' instead of required
                'version'               => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
                'force_activation'      => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
                'force_deactivation'    => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
                'external_url'          => '', // If set, overrides default API URL and points to an external URL
            ),
            array(
                'name'                  => 'Widget Importer & Exporter', // The plugin name
                'slug'                  => 'widget-importer-exporter', // The plugin slug (typically the folder name)
                'source'                => 'https://downloads.wordpress.org/plugin/widget-importer-exporter.zip', // The plugin source
                'required'              => false, // If false, the plugin is only 'recommended' instead of required
                'version'               => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
                'force_activation'      => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
                'force_deactivation'    => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
                'external_url'          => '', // If set, overrides default API URL and points to an external URL
            ),
    

    Hope that helps!

    Kind Regards,
    Charles

    Attached files:  Polytechnic Documentation v.0.7.pdf